Saturday, December 18, 2010

HMC Commands for Fresher

Hi Folks,

Here is the basic commends which help you to access HMC.

NOTE that execution of HMC commands can be very very slow.


First log in on the hmc via SSH using username hscroot, example command (from an AIX box):
ssh hscroot@hmctest
or
ssh hmctest -l hscroot

Note : while doing the ssh itself you can directly apply the commands
Eg: ssh hscroot@anrh0101 lslpars

To list status of all systems and LPARs connected to an HMC:
lslpars
lslpars --wide

To issue a soft reset to an LPAR:
chsysstate -m -r lpar -n -o reset


To close a console connection:
The session can be ended by typing
~ and . as the first characters on a line.

To view state and operator panel (LED/LCD display) of an LPAR:
lssyscfg -r lpar -m -n

To view state and operator panel (LED/LCD display) of a system running in FullSystemPartition mode (note the -n):
lssyscfg -r sys -n

To Start a terminal
mkvterm -m machine_name -p lpar - start a terminal

To Close a terminal
rmvterm -m machine_name -p lpar - close terminal connection

To reboot an lpar
chsysstate -r lpar -m machine_name -o shutdown --immed --restart -n lpar_name - reboot an lpar

To access LPAR console for diffrent Managed system from HMC

#vtmenu

Note : It will display a menu from that we have to choose our node.

To reboot the HMC:
hmcshutdown -t now -r

Friday, December 17, 2010

Pre check to change the faulty adapter

Hi Friends,

If you have any issue with Adapter check with the errpt code and do the wrap test.

First run the command #diag
a) Advanced Diagnostics Routines
b) Problem Determination/System Verification
c) Select adapter fcs3 from the list
d) F7 to commit
e) Select Wrap Test
f) Ask the CE to run the Wrap Test

Choose the option (e)

if wrap test is successful

go for cfgmgr. Then list the customized devices and pre-defined devices and the check the faulty adapter.

Thursday, December 16, 2010

To compare the directories in AIX

Who one doesn't have the access to man page kindly go through this...

dircmp Command

Purpose

Compares two directories and the contents of their common files.

Syntax

dircmp [ -d ] [ -s ] [ -w num ] Directory1 Directory2

Description

The dircmp command compares the two directories specified by the Directory1 and Directory2 parameters and writes information about their contents to
standard output. First, the dircmp command compares the file names in each directory. If the same file name appears in both, the dircmp command
compares the contents of both files.

In the output, the dircmp command lists the files unique to each directory. It then lists the files with identical names in both directories, but
with different contents. If no flag is specified, it also lists files that have identical contents as well as identical names in both directories.

The diff -r command offers a function similar to the dircmp command.

How to compare directories - AIX

Hi Folks,

Here is the script to compare the Directories in AIX.

for i in `cat /tmp/'
do
ls -l $i
if [ $? -eq 0 ]
then
echo "Found same filename $i"
fi
done

We have more options to compare the directories. Check the man page for dircmp too...

Sunday, December 12, 2010

AIX Documents

Redbooks
IBM System p5 Approaches to 24x7 Availability Including AIX 5L
http://www.redbooks.ibm.com/Redbooks.nsf/RedbookAbstracts/sg247196.html?Open


Advanced POWER Virtualization on IBM System p5
http://www.redbooks.ibm.com/Redbooks.nsf/RedbookAbstracts/sg247940.html?OpenDocument

Problem Solving and Troubleshooting in AIX 5L
http://www.redbooks.ibm.com/Redbooks.nsf/RedbookAbstracts/sg245496.html?OpenDocument

Technical Database for AIX
http://www14.software.ibm.com/webapp/set2/srchBroker/views/srchBroker.jsp

Useful links to learn AIX

Learn more about AIX
AIX & UNIX developerWorks zone
http://www-128.ibm.com/developerworks/aix

PowerAIX.org mit indischer User Group
http://www.poweraix.org/groups?groupid=5


Other useful Websites
Support for IBM System p servers
http://www-03.ibm.com/servers/eserver/support/unixservers

Technical Database for AIX
http://www14.software.ibm.com/webapp/set2/srchBroker/views/srchBroker.jsp

Redbooks domain for IBM System p
http://www.redbooks.ibm.com/portals/UNIX

Virtual Loaner Program
http://www.ibm.com/servers/enable/site/vlp

Saturday, December 4, 2010

Basic commands of AIX

HI Friends,

The following commands should be handy for AIX servers

In AIX 5.2, the 32-bit kernel is installed by default. In AIX 5.3, the 64-bit kernel is installed on 64-bit hardware and the 32-bit kernel is installed on 32-bit hardware by default.


How would I know if my System p machine (hardware) is 32-bit or 64-bit?

To display if the hardware is 32-bit or 64-bit, type:

#bootinfo -y


To display the number of hard disks on your system, type:

#lspv

How do I list information about a specific physical volume?

To find details about hdisk1, for example, run the following command:

#lspv hdisk1

How do I get a detailed configuration of my system?

Type the following:

#lscfg

The uname command provides details about your system.

#uname -p
Displays the chip type of the system. For example, PowerPC.

#uname -r
Displays the release number of the operating system.

#uname -s
Displays the system name. For example, AIX.

#uname -n
Displays the name of the node.

#uname -a
Displays the system name, nodename, version, machine ID.

#uname -M
Displays the system model name. For example, IBM, 9114-275.

#uname -v
Displays the operating system version.

#uname -m
Displays the machine ID number of the hardware running the system.

#uname -u
Displays the system ID number.

The uname command provides details about your system.

#uname -p
Displays the chip type of the system. For example, PowerPC.

#uname -r
Displays the release number of the operating system.

#uname -s
Displays the system name. For example, AIX.

#uname -n
Displays the name of the node.

#uname -a
Displays the system name, nodename, version, machine ID.

#uname -M
Displays the system model name. For example, IBM, 9114-275.

#uname -v
Displays the operating system version.

#uname -m
Displays the machine ID number of the hardware running the system.

#uname -u
Displays the system ID number.

Fresher : Basic things to do as a Admin - For safer side

Hi Everyone... The following comments are very useful for the beginerrs in AIX

Admin role :Once logged into the AIX server run the follwing commands and save the output.

1. oslevel -s
2. id
3. uptime
4. w or who
5. lsvg
6. lsvg -o
7. lsvg rootvg
8. df -k
9. date

If you are suppose to work on any critical issue please run the follwing commands too and save the output

9. prtconf
10. ps -ef
11. ps -ef|grep root
12. ifconfig -a
13. netstat -nr
14. errpt
15. lsvg

Save this output in a seperate notepad / Wordpad then start to work on the issues. If in case of emergency these output data will help the senoiurs to rectify

Useful commends for AIX Fresher

First let us see what is AIX..

AIX (Advanced Interactive eXecutive, pronounced "a i ex") is a series of proprietary Unix operating systems developed and sold by IBM for several of its computer platforms. Originally released for the IBM 6150 RISC workstation, AIX now supports or has supported a wide variety of hardware platforms, including the IBM RS/6000 series and later IBM POWER and PowerPC-based systems, IBM System i, System/370 mainframes, PS/2 personal computers, and the Apple Network Server. AIX is based on UNIX System V with 4.3BSD-compatible extensions. The AIX family of operating systems debuted in 1986, became the standard operating system for the RS/6000 series on its launch in 1990, and is still actively developed by IBM, and currently supported on IBM Power Systems alongside IBM i and Linux.

This is the first OS Utilize the JFS (Journeled file system)